注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

沙漠里de烟雨

原创分享,禁止转载

 
 
 

日志

 
 

思科路由的小结与剖析  

2011-02-18 16:53:30|  分类: 网络管理与应用 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
 

静态路由

R(config)#ip route 目的网络 子网掩码 下一跳入口地址

R(config)#ip route 目的网络 子网掩码 下一跳入口地址 AD(管理距离)  /*浮动路由

默认路由:(config)#ip default-network 192.168.1.0 ――――192.168.1.0为到对方的网络。

缺省路由:(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1 ―――172.16.1.1为下一跳接口IP。

这两个的结果有些差异,第一条命令所指的网络更具体些。不过各有各的优点。其实它们的称呼可以互换,没有绝对的界线。

 

RIP路由

注意:RIPv1不支持无类子网,故不能处理非连续子网的汇总。

R(Config)#router rip           ――――――――――启用RIP进程

R(config-router)#Version 2   ―――――――――――应用版本2

R(config-router)#Network 子网 ――――――――――通告子网(直连的)

 

R(config-router)#no version 2  ―――――――――取消版本2,应用版本1

R(config-router)#no network 子网 ――――――――取消子网的通告

 

R(config-if)#ip send version 1   ――――――――在某接口发送版本1的信息

R(config-if)#ip receive version 2  ――――――――在某接口发送版本2的信息

R(config-if)#ip send version 1 2  ――――――――在接口同时发送版本1、2的路由信息

R(config-if)#ip receive version 1 2 ――――――――在接口同时接收版本1、2的路由信息

 

R(config-router)#no auto-summary ―――――――关闭自动汇总(汇总有时不准确甚至不正确,为减少路由条目,采用手工汇总)

R(config)#Int s0      ――――――――――――基于接口

R(config-if)#ip rip summary-address 网络 掩码 ――――手工汇总

 注意:

          RIPv1/IGRP: 默认开启自动边际汇总,且只能汇总连续的,主类的网络,不能手工汇总无类的、不连续的子网(不论是不是连续的,或只有一条这样的子网),为了路由的准确,推荐关闭其自动汇总。IGRP会有一条精确路由,而且还有一条汇总路由,即使它只有一条子网。

   RIP(v2): 默认开启自动边际汇总,当存在不连续子网时,会出现路由条目的错误,推荐关闭其自动汇总,然后手工汇总。汇总都是在连接其它网络的接口上进行的。

   EIGRP: 和RIP(v2)一样,一般情况下都是推荐关闭它,进行手工汇总,使其路由表尽量精简。

   OSPF: 默认不开启自动边际汇总。

           RIP,IGRP,EIGRP,OSPF默认开启等开销负载均衡,RIP,OSPF不支持非等开销负载均衡。通过配置,可以让IGRP,EIGRP实现非等开销负载均衡

 

IGRP/EIGRP路由

R(config)#router igrp 100  ――――――启用IGRP进程,AS为100,全局的、传递的

R(config-router)#network 子网

R(config)#router eigrp 100

R(config-router)#network 子网  ――――(直连的)

解:上面的配置在同一个路由器上运行着两种协议,且在IGRP和EIGRP相交的网络上实现了平滑地自动重发布即两个网络的AS(自治系统)号相同就可实现重发布而无须作任何其它配置,这是一个令人振奋的网络,然而必须清楚的是,只有在这两个网络的所有路由器都是思科的产品时才有让你得到这种安逸享受的可能(^_^)。

通告的是直连的子网,包括局域网,不能因为它不会辨识三层IP包而认为没有在这个接口通告的必要,因为你得让其它网络能知道这个网络的存在,所以,如果你想要过滤其它网络向局域网内主机和交换机通告路由信息以节省带宽,可以把它(内网的接口)设置为被动接口,这样,它接收的路由信息就不会通告给局域网内的主机,交换机,方法如下:

R(config)#router rip 

R(config-router)#passive-interface e0 ―――――只接收更新包而不发送更新包

 

R(config-router)#no router eigrp 100   ――――――关闭EIGRP进程如果还有其它的EIGRP进程,即AS不是100,照样不会被关闭。说明它与AS是分不开的。

R(config)#int s1

R(config-if)#bandwidth 1544

R(config-if)#ip bandwidth-percent eigrp 100 80 ――――100为AS号,80为总带宽的80%

(默认是50%用于交换路由信息,修改它会影响路径的选择。)

R(config)#router eigrp 100

R(config-router)#no auto-summary       ――――――关闭自动汇总

R(config)#int s0       ―――――――――――基于接口

R(config-if)#ip summary-address eigrp 100 网络号 掩码――手工汇总(注意与RIP的差别,如下行)

R(config-if)#ip rip summary-address 网络 掩码 ――――手工汇总(RIP的手工汇总)

常用show命令:

Show ip route         ―――――――――――查看路由表

Show ip eigrp neighbors [details]   ――――――查看邻居

Show ip eigrp int [s0][details]  ――――――查看接口信息

Show ip eigrp topology [all-links] ――――――查看拓扑信息

Show ip eigrp topology 192.168.2.0 ―――――查看关于拓扑表条目的具体信息

Show ip eigrp traffic    ―――――――查看eigrp的相关信息

IGRP和EIGRP的非等开销负载均衡

R(config)#router eigrp 100

R(config-router)#variance 2  ―――variance容忍度(1~128,默认为1)等于次佳路径 / 最佳路径,值取整数。可通过查看其top表大致算出。

R(config)#ip default-network 子网  ――――缺省路由(注意与RIP的不同,如下三行),通常应用在未端网络且只有一个出口的路由器上

                R (config)#ip route 0.0.0.0  0.0.0.0   出口接口

               R (config-router)redistribute connected

               R (config-router)default-information originate

R(config)#router eigrp 100

R(config-router)#network 172.16.8.0 0.0.0.255  ―――― 一次性通告一个连续网络(有时行不通,可能与版本有关,不推荐使用)

两点补充

1、默认情况下,路由器是基于目的地的交换(即快速交换),即当第一次找到去往某地的路由时,便把此路由缓存起来以备以后再用,当第二次去住此地时不会去查路由表,而是直接在缓存中读取,这就加快了路由的速度。另一种方式是基于分组的交换(即分组交换),即每次都查路由表。

R(config)#int s1

R(config-if)#ip route-cache          ――――――――快速交换(缓存路由)

R(config-if )#no ip route-cache   ―――――――――分组交换(每次路由都得查路由表)

2、清空路由表,使其重新生成路由,相当于刷新路由表:

#clear ip route *             ――――――――――清除所有动态路由条目

#clear ip route 192.168.10.0  ―――――――――清除IP路由表中的某条特定路由条目

注意:在企业中执行这条清除所有动态路由条目的命令时,有可能会使大量的用户数据丢失,此时只能采取第二个命令。当然在实验中您可以随心所欲的用它。

 

OSPF路由

R(config)#router ospf 100  ―――――启用OSPF进程,100为进程号本地有效,不传递

R(config-router)#network 10.1.0.0 0.0.0.255 area 0  ――――通告网络,并划分到区域中。

R(config-router)#network 192.168.1.2 0.0.0.0 area 0  ――――将接口划分到区域中。

R(config)#int loopback 0

R(config-if)#ip add 192.168.2.12 255.255.255.255    ――――(推荐)用主机地址对回环接口地址的指定。

注意:你会发现OSPF的网络通告与众不同。RIP,IGRP,EIGRP无须使用通配符(反掩码),对于OSPF,它既要将接口划入到区域中,也要把子网划入到区域中,所以为了区分,用通配符来确定,对于串口,即可把它当作接口划入到区域中,又可把它当作子网划入,使用网络通告是为了将局域网通告出去,此时又可以把多个连续的子网用一条超网路由通告出去。此时的子网掩码只能有一个用途:证明这几个子网是连续且可汇总为一条超网。

在同一个区域中,当为多路访问的网络模式时,有必要进行DR,BDR的选举。如果想人为干涉它们的“内政”,可以修改它们的优先级或RID(路由器ID,一般是loopback地址)但要让其立即生效,则唯有重启网络

R(config)#Int s0    ――――――在接口下修改优先级,因为一个路由器的几个接口可以属于不同的区域,因此这个路由器既可作为这个区域的DR,又作那个区域的DR,所以它是基于接口的配置。

R(config-if)#Ip ospf priority 100  ――――――修改优先级,默认值是1,范围是0~255, 0表示不参与“政治”选举,被剥夺了“政治权力”终身。

 

R(config)#int s0

R(config-if)#ip ospf cost 1000  ――――――修改开销值可人为地操控路由的选择。

 

R(config)#router ospf 100

R(config-router)#auto-cost reference-bandwidth 1000 ――――修改参考带宽(Mb/s,默认是100Mb/s,当出现1000M,如千兆以太网,带宽会是小于1的小数,即100/1000=0.1,故此修改是很有必要,它在进程模式下修改的,故在本地有效,不要求别的路由器也一样。)

R(config)#int s0

R(config-if)#ip ospf hello-intervla 5     ――――――修改hello时间

R(config-if)#ip ospf dead-interval 20  -―――――修改Dead周期(最好为hello的4倍,否则会产生波纹效应,影响邻居的建立。这两个参数一般推荐不作修改。)

常用 show命令:

Show ip protocols

Show ip route

Show ip ospf

Show ip ospf interface

Show ip ospf neighbors [detail]

Show ip ospf database

多区域中的OSPF配置

末节区域:

R(config-router)#area 2 stub    ―――――――area 2中的所有路由器包括ABR在内都是同一配置。

完全末节区域:

R(config-router)#area 2 stub  -―――――在区域2中除了ABR外所有的路由器上配

R(config-router)#area 2 sub no-summary  ――――在区域2中的ABR路由器上配置

次末节区域:

R(config-router)#area 2 nssa  ――――在nass中所有路由上配,包括ABR,ASBR在内。

R(config-router)#area 2 nass no-summary ―――――在ABR上配,使其成为完全末节。过滤了LSA3,LSA4的路由信息。

ABR上的路由汇总:

R(config)#router ospf 100   ――――――――――基于进程

R(config-router)#area 2 rang 子网 掩码 ――――将区域2内的连续子网汇总到0域

ASBR上的路由汇总:

R(config)#router ospf 100    ――――――――――基于进程

R(config-router)#summary-address 子网 前缀(掩码)―――将外部路由汇总到nssa域。

 

注意area 0一般不进行汇总,否则可能会选择次优路径。经过比较你就会发现RIP,IGRP/EIGRP与OSPF的手工汇总各不相同,现比较如下:

RIP:        R (config-if)#ip rip summary-address 网络 掩码;---------接口模式下

IGRP/EIGRP: R(config-if)#ip summary-address eigrp 100 网络 掩码;-------接口模式下

OSPF:      R (config-router)#area 2 rang 子网 掩码 ――――将区域2内的连续子网汇总到0域(路由模式下的ABR)

R(config-router)#summary-address 子网 掩码―――将外部路由汇总到nssa域。(路由模式下的ASBR,也即重发布)

R(config-router)#summary-address 子网 掩码 ―――将外部路由汇总到0区域中,此时,此路由器既是ABR,又是ASBR。

 

区域间流量必须经过主干区域0才能转发所以域间关系一般是以星形的拓扑结构来架构网络的。但如果某些原因无法与0域相连,则此域可经过与某非0域建立虚拟链路与0域相连,如区域3想与区域1建立虚电路:

R(config)#router ospf 100

R(config-router)#area 1 virtual-link 192.168.1.1  ――192.168.1.1为对端ABR的路由器ID.

R(config)#router ospf 200

R(config-router)#area 1 virtual-link 192.168.2.2 ――192.168.2.2为对端ABR的路由器ID

现在来对比一下RIP,IGRP/EIGRP,OSPF,BGP中的基本路由配置及其意义的不同:

RIP:

R(Config)#router rip           ――――――――――启用RIP进程

R(config-router)#Version 2   ―――――――――――应用版本2

R(config-router)#Network 子网 ――――――――――通告子网(直连的)

 

IGRP/EIGRP:

R(config)#router igrp 100  ――――――启用IGRP进程,100为AS号,全局的、传递的。

R(config-router)#network 子网   ――――――――――通告子网(直连的)

 

OSPF:

R(config)#router ospf 100  ――――――――――――100为进程号,本地有效,不传递。

R(config-router)#network 10.1.0.0  0.0.0.255  area 0 ——――――通告网络,并划分到区域中。

 

BGP:

R(config)#router bgp 22  ―――――启用BGP进程,22为AS号,全局的,传递的。

R(config-router)#neighbor 12.0.0.1 remote-as 23

R(config-router)#network 192.168.1.0 ―――――将自己路由表中存在的路由通告给邻居,可以是直连的、静态的或IGP学习到的网络。

R(config-router)#network 192.168.1.0 mask  0.0.0.255 ―――当为子网时,推荐指定反掩码来指定详细网络,否则容易造成路由“黑洞”。

 

重发布

重发布(动态路由间的重发布时必须要考虑其度量值,当RIP发布到EIGRP时,必须将跳数转化为带宽,延时等,而EIGRR发布到RIP时,只须给定一个默认跳数即可。在OSPF中,只有ASBR才有资格实现重发布)

1) 直连路由、静态路由的重发布:

R(config)#router eigrp 100

R(config-router)#redistribute connected [metric 100000 100 255 1 1500]――所有直连的外部网络(未划入到NSSA域的接口所直连的网络)都会注入到NSSA中,[ ]表示可选项.

R(config-router)#redistribute static [metric 100000 100 255 1 1500]-――所有手工输入的静态路由都会注入到EIGRP 100的区域中。

R(config)#router ospf 100

R(config-router)#redistribute connected [metric 20]―――――20为开销值

R(config-router)#redistribute static [metric 20]

2) 单向重发布:

RIP重发布到EIGRP:

R(config)#router rip

R(config-router)#net 172.24.0.0    ――――RIP通告准备要注入到EIGRP中去的网络。

R(config)#router eigrp 100

R(config-router)#redistribute rip metric 1000 100―――将RIP网络全部注入到EIGRP 100的网络中。

EIGRP重发布到RIP:

R(config)#router eigrp 100

R(config-router)#net 172.16.0.0 ―――――EIGRP通告准备要注入到RIP中去的网络。

R(config)#router rip           

R(config-router)#redistribute eigrp 100 metric 2

RIP重发布到OSPF:

R(config)#router rip

R(config-router)#net 172.16.0.0

R(config)#router OSFP 100

R(config-router)#redistribute rip metric 1000 ――――1000指的是cost值。

注意:如果要重发布的是某个子网,则后面一定要跟subnets关键字,如:

R(config-router)#redistribute eigrp 100 metric 2 subnets (或干脆)

R(config-router)#redistribute eigrp 100 subnets

 

路由策略

注:策略路由凌驾于动态路由之上。因为一个IP包经过路由器时先执行ACL,如果允许才会去查路由表,所以ACL的路由优于路由表中的路由,即便是直连也是如此。

1、对路由更新包进行流量控制:

被动接口:

R(config)#router rip

R(config-router)#passive-interface e0 ―――――只接收更新包而不发送更新包

 

R(config)#router eigrp 100

R(config-router)#passive-interface e0 ―――――影响邻居建立,故无法收发更新包

 

R(config)#router ospf 100

R(config-router)#passive-interface e0 ―――――影响邻居建立,故无法收发更新包

 

分布控制列表:

R(config)#access-list 1 deny 192.168.1.0 0.0.0.255  ――――定义访问控制列表。

R(config)#access-list 1 permit any  -――――对cisco产品记得最后一句允许所有。

R(config)#router rip   ――――――――――――对RIP协议更新包进行流量过滤。

R(config-router)#distribute-list 1 out s0 ―――将访问控制列表应用于接口的出方向,如果离开路由器则为out, 进入路由器则为in.(路由器模式)

对包括用户数据进行的流量控制:

1)ACL

标准:

R(config)#access-list 1 deny 192.168.2.0 0.0.0.255

R(config)#access-list 1 permit any ―――――――应不要忘记最后加上这一条命令。

R(config)#int s0

R(config-if)#ip access-grop 1 out  ―――――应用到接口及控制方向(接口模式)

扩展:

R(config)#access-list 100 deny tcp 192.168.2.0 0.0.0.255 host 10.0.0.1 eq 23

R(config)#access-list 100 permit ip any any  ―――应不要忘记最后加上这一条命令。

R(config)#int s0

R(config-if)#ip access-group 100 in  ――――应用到接口及控制方向

ACL只能过滤经过的数据,而不会过滤掉自己产生的数据。

2)路由图

R(config)#access-list 1 deny 192.168.1.0 0.0.0.255  ―――定义ACL

R(config)#access-list 1 permit any

R(config)#route-map ABC permit 22  ―――――――定义路由图

R(config-router-map)#match ip address 1 ―――――匹配1号ACL

R(config-router-map)#set int s0    ――――――出口接口的绑定

R(config)#int e0    ――――――――――――――局域网接口

R(config-if)#ip policy route-map ABC  ――――――将路由图应用到局域网入口

小提示:因为如果ACL配置中出现有错误,删去一条则意味着全部都删除了,所以,为了减少不必要的麻烦,可以用记事本将ACL配置记录下来,以防不时之需。

 

NAT

1)静态NAT:

R(config)#ip nat inside source static 192.168.1.2 200.200.100.252

R(config)#int e0

R(config-if)#ip nat inside

R(config)#int s0

R(config-if)#ip nat outside

2)动态NAT:

R(config)#access-list 1 permit 192.168.1.0 0.0.0.255

R(config)#ip nat pool  aaa  public 200.200.100.1 200.200.100.253 netmask 255.255.255.0

       R(config)#ip nat  inside  source  list  1  pool  aaa  overload

R(config)#int e0

R(config-if)#ip nat inside

R(config)#int s0

R(config-if)#ip nat outside

3)端口地址转换(PAT):

R(config)#access-list 1 permit 192.168.1.0 0.0.0.255

R(config)#ip nat inside source list 1 int s0 overload

R(config)#int e0

R(config-if)#ip nat inside

R(config)#int s0

R(config-if)#ip nat outside

 

BGP

IGP是用于发现路由的协议,而BGP是建立在IGP基础之上的用于不同策略的AS之间交换路由信息的协议。BGP的作用是缺省路由、重发布所无法完全替代的,比如:它能针对AS之间策略的不同而作出安全、精确的策略控制,而这些是缺省路由、重发布所无法企及的。然而并非所有的AS之间都必须用BGP,下面几种情况就得考虑它的使用与否:

1)只有一条通往internet或者其他AS的连接;

2)internet的路由策略与路由选择与本AS无关;

3) 路由器性能太低;

4) 管理员对BGP的理解有限;

5) AS之间带宽很窄。

BGP的算法就能保证路径的无环,它是通过AS序列来实现的。

BGP的4种不同的路径属性类型:公认必遵,公认自决任选可传递任选不可传递。它们是执行路由策略的依据。

和IGP不同,BGP是不允许在同一个路由器上运行多个BGP进程,即一台路由器不能属于一个以上的AS的。

R(config)#router bgp 22

R(config-router)#network 192.168.1.0 mask 255.255.255.192

network这条命令是让BGP选择存在于本路由器中路由表的一条子网192.168.1.0/26(如果没有mask参数,则说明通告的是一个C类的网络,而非子网),一旦通告,BGP就迫不及待地将它传播出去。注意这与IGP的网络通告是不同的,它们通告的一般都是直连的,而BGP通告的是存在于路由表中的,不管是直连的,重发布过来的,还是IGP学习到的,但是如果通告了一个路由表中没有的网络,它是不会将此信息传播出去的(必竟是眼见为实嘛),而IGP不是这样的,它完全听信“流言”,你人为地捏造了一个子虚乌有的网络,它就完全听信了,就认为这是理所当然的而通告出去,给别的路由器造成了一种可达的假像。

所以在做IGP路由通告时务必认真!

R(config)#router bgp 200

R(config-router)#neighbor 192.168.1.2 remote-as 200

R(config-router)# neighbor 192.168.1.2 update-source loopback 0

我们推荐使用环回口的接口地址来与IBGP邻居建立TCP连接,因为在一个大的AS内,通常是有多条路径可以让它们形成邻居关系,一旦当前路径故障,则可以选择另一路径与之建立邻居,但是如果是把接口作为邻居的桥梁,一旦down了,就无法与先前的邻居恢复邻居关系了,即使还有另一条路径可以使用。作为EBGP邻居,就没有这个必要了,因为EBGP邻居通常是点对点的,一旦链路故障,则穷途末路了。

#clear ip bgp *       ―――――――清除路由表的所有bgp条目。

一旦最新更改了新的策略,就应当强行清除BGP的路由表,重置BGP会话使修改生效。在实验室里大可放心去做,但在一个正在运营的企业网的路由器上就不应当这样,只能清除与邻居的路由条目,使会话重建:#clear ip bgp 13.0.0.1   --------13.0.0.1为邻居的接口IP。

如果为了连这条线路都不能断,可在此命令之前写一条缺省路由到此路由表中:(最后网关)

R(config)#ip route 0.0.0.0 0.0.0.0 13.0.0.1 210―――因为EBGP的AD为200,这里它作为浮动路由。

R(config)#router bgp 22

R(config-router)#neighbor 13.0.0.1 remote-as 23

R(config-router)#neighbor 13.0.0.1 ebgp-multihop 2

邻居多跳只适用于EBGP,而不适用于IBGP。虽然IBGP可以跨路由器建立IBGP邻居,但它们都在同一个自治系统AS内,无多跳可言,故不要断章取义。

BGP不会把从IBGP对等体处学到的路由通告给其他IBGP,即通告不会让第二个IBGP去泄密,否则有可能你把这个秘密告诉他,再经过几个人之后,最后一个知道此秘密的人却以为你不知道而把它告诉给你,到时你会有什么感受?是不是有点被人出卖的感觉?所以为了能够让其他IBGP邻居学到AS内的所有的BGP路由,它们必须是全互联的(逻辑上的)。与其被人出卖,不如自己一个个去告知。

因为BGP是基于TCP协议的,所以它的可靠性就使得它在IBGP路由更新时必须同步,别人传言的信息不一定可靠,自己必须能到达,才把它写进路由表,否则会造成人家丢过来一个包,你却让它石沉大海。而EBGP邻居之间就无所谓同步问题,一旦接收对等体的通告,就将它写进路由表,而不管是否经过多少跳,是否可达。

BGP属性:

1、 下一跳(next hop): ――――公认必遵,代码为3。

R(config-router)#neighbor 13.0.0.1 next-hop-self

2、原子汇总(Atomic Aggregate):――――公认自决,代码为6。

R(config-router)#aggregate-address 160.0.0.0 255.0.0.0 summary-only

注:如果不加summary-only参数,则会使详细子网连同那条汇总而成的超网路由一起通告出去。这样做也就没有什么必要去汇总了,所以推荐加上后面那条命令。

3、路径(AS Path):  ―――――公认必遵,代码为2。

R(config)#route-map ABC permit 33

R(config-route-map)#set as-path-prepend 9 10――――――增加伪编号9和10。

私有转化为公有(NAP):

R(config)#router bgp 11――――――――――连接私有AS网络的公有AS,即公网边界

R(config-router)#neighbor 172.16.220.2 remote-as 65501――――65501为需转化的私有AS。

R(config-router)#neighbor 192.168.63.2 remote-as 33 ―――连接AS 11的公网AS,即私有AS想与之通信的AS.

R(config-router)#neighbor 192.168.62.3 remove-private-as――移除私有AS,对外呈现公有AS.

4、本地优先级(Local preference):  ―――――公认自决,代码为5。

R(config-router)#bgp default local-preference 200 ――――200为本地优先级。

5、权重(Weight): (cisco专用)

R(config-router)#neighbor 2.2.2.2 weight 100

R(config-router)#neighbor 3.3.3.3 weight 150

6、多出口鉴别(MED):  ―――――任选不可传递,代码为4。

R(config)#route-map ABC permit 10 ―――――――定义路由图

R(config-route-map)#set metric 50 ―――――――设定MED 值

R(config)#router bgp 33  ――――――――――――在路由模式下

R(config-router)#neighbor 4.4.4.4 route-map ABC out――――应用路由图

R(config-router)#bgp always-compared-med――――强行允许比较源于外部AS的med

7、起源(Origin):  ―――公认必遵,代码为1。

无需配置,BGP自动开启。

 

本地优先级(Local preference),权重(Weight),多出口鉴别(MED)的应用场合

Local preference:一个AS内多个路由器的多个出口。只能针对去的流量做路径选择。(用路由图来实现从多个出口选择适合本地策略的路径。)

Weight: 一个路由器多个AS出口。

MED: 一个(或多个)AS间多个入口。只能针对进来的流量做路径选择。(用路由图来实现多个入口的最适合本地策略的路径选择。)

常用命令:

show ip bgp ―――――――――查看bgp表。

show ip bgp summary

show ip bgp neighbor ―――――――――查看bgp邻居信息。

Clear ip bgp * ―――――――清除bgp表,使BGP会话重建。

 过滤BGP路由:

1、用分布控制列表:

R(config)#access-list 101 permit ip 172.16.0.0 0.0.0.0 255.255.0.0 0.0.0.0

R(config)#access-list 101 deny ip 172.16.0.0 0.0.255.255 255.255.0.0 0.0.255.255

R(config)#access-list 101 permit ip any any

R(config)#router bgp 33

R(config-router)#neighbor 172.16.1.2 remote-as 33

R(config-router)#neighbor 172.16.20.1 remote-as 11

R(config-router)#neighbor 172.16.20.1 distribute-list 101 out

注意:第二条命令表明,其网络号和掩码都必须用通配符(反掩码)来匹配。

2、用ip prefix-list命令:(cisco专用)

R(config)#ip prefix-list ABC deny 0.0.0.0/0

R(config)#ip prefix-list ABC permit 172.16.0.0/16

R(config)#router bgp 100

R(config-router)#neighbor 192.168.1.1 remote-as 200

R(config-router)#neighbor 192.168.1.1 prefix-list ABC out

  评论这张
 
阅读(1442)| 评论(0)
推荐

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018