登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

沙漠里de烟雨

原创分享,禁止转载

 
 
 

日志

 
 

帧中继的浅析-----星型拓扑的点对多点模式与点对点模式的比较  

2011-02-11 23:14:13|  分类: 网络管理与应用 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

一、在开始这个分析之前,这里先阐述一些相关概念:

1、帧中继是一种比较常用的广域网接入技术,它主要用于将几个地理距离相距较远的分支节点通过互连网(ISP的帧中继网络)来实现信息传递与资源共享,如一个大企业,总公司与分布在全国各地的分公司通过帧中继的接入方式实现数据交换共享。

2、帧中继工作在OSI参考模型的物理层与数链层。

3、帧中继需依赖TCP上层协议进行差错控制,所以较其前身X.25(通过自身负责差错控制)更快。

4、帧中继使用虚电路(VC)进行连接,且主要用永久虚电路(PVC)进行连接。

5、帧中继是一种采用包交换技术的远程接入技术,作用的范围仅限于本地环。帧中继技术基本上支持目前大多数数据传输协议,从而实现了与上层数据的无关性。

6、虚电路-----在确保通信的两个网络设备之间建立的逻辑电路。

7、DLCI(数据链路连接标识)-----两种说法:用来标识路由器和帧中继交换机之间的逻辑电路的数字;负责对数据的传输流向进行标识的一种数字标号。帧中继交换机将一对路由器之间的DLCI对应起来,用以建立一个永久虚电路(PVC),DLCI的重要意义在于,它标识本地路由器被连接到帧中继交换机所涉及的端点,它仅适用于本地局域网络。

8、LMI(本地管理接口)-----一个在用户终端设备(CPE)和帧中继交换机之间传送的信令标准,它负责路由器与ISP的帧中继交换机之间的PVC建立与PVC激活状态的维持。

9、帧中继网络拓扑结构主要有三种:

全互联型------优点:网络冗余度高,网络健壮;缺点:费用高,可扩展性差。

帧中继的浅析-----星型拓扑的点对多点模式与点对点模式 - 漠雨 - 沙漠里de烟雨

 

星型------优点:可扩展性好,费用低;缺点:网络无冗余,健壮性差,中心节点故障,则全网瘫痪。

帧中继的浅析-----星型拓扑的点对多点模式与点对点模式 - 漠雨 - 沙漠里de烟雨

 

混合型(星型为主,部分节点互联)------优势互补,重要或有需求的互联。

帧中继的浅析-----星型拓扑的点对多点模式与点对点模式 - 漠雨 - 沙漠里de烟雨

 

10、企业连接内部网络使用的主流技术主要有三种:

DDN专线------点对点接入模式,传输介质使用传统的电话线路,独享带宽,贵,带宽在64Kbps----155Kbps。

数字链路------点对点接入模式,传输介质使用光纤,独享带宽,贵,带宽为2Mbps。

帧中继------ 点对点模式或点对多点模式,适用多种传输介质,共享带宽,廉价,带宽在64Kbps----155Mbps。

 

二、星型拓扑下的点对多点模式:

下面以三个节点来解析星型拓扑下的点对多点模式的帧中继的实现,如下所示:

帧中继的浅析-----星型拓扑的点对多点模式与点对点模式 - 漠雨 - 沙漠里de烟雨

 假设:

R为某企业的公司总部的网络的边缘路由器;

R1为其在异地的分公司1的网络的边缘路由器;

R2为其在另一地方的分公司2的网络的边缘路由器;

E0为边缘路由器上的连接公司内网的以太网接口;

S0为边缘路由器上的串口,IP已经如下所示作了标明;

DLCI:200与DLCI:100形成关联,建立起PVC 1虚电路,实现R与R1通信;
DLCI:300与DLCI:400形成关联,建立起PVC 2虚电路,实现R与R2通信;
采用RIP路由协议;
要求R1与R2不能通信。

如下所示拓扑详图:

 

帧中继的浅析-----星型拓扑的点对多点模式与点对点模式的比较 - 漠雨 - 沙漠里de烟雨
 
 上图中红线代表与帧中继交换机相连的介质,如电话线或光纤等。虚线代表建立的PVC虚电路。
 在上图中你会发现,R、R1、R2在同一网段,即192.1.1.0/24网段,因而在同一广播域,此时PVC 1与PVC 2在同一网段,R路由器的S0接口得承载两个虚电路,所以通过在帧里封装DLCI号,根据IP包里的对方IP地址,来建立关联映射,以此就能区分数据的流向,也即可以区分数据是通过哪个PVC到达对方的。映射方法是在同一PVC中,用本地路由器R的DLCI与相对应的对端路由器IP进行映射。
因为采用的是RIP这种经典距离矢量路由协议,所以存在水平分割问题,致使R1与R2不能交换路由,无法互访,然而此例就是利用这个缺点来实现R1与R2的隔离。
 
配置方法如下:
R:
R(config)#interface s0 multipoint                                         // 点对多点
R(config-if)#ip address 192.1.1.1 255.255.255.0                //设S0接口的IP
R(config-if)#encapsulation frame-relay ietf                          //封装帧中继类型为IETF
R(config-if)#frame-relay lmi-type ansi                                  //设置帧中继LMI类型为ANSI
R(config-if)#frame-relay map 192.1.1.3  200                       //本地DLCI=200与对端路由器R1的IP做关联映射
R(config-if)#frame-relay map 192.1.1.4  300                       //本地DLCI=300与对端路由器R2的IP做关联映射
R(config-if)#no inverse-arp                                                  //禁止反向域名解析
R(config)#router rip                                                             //启用RIP路由协议
R(config)#network 192.1.1.0                                                //通告网段192.168.1.0
R1:
R1(config)#interface s0
R1(config-if)#ip address 192.1.1.3 255.255.255.0
R1(config-if)#encapsulation frame-relay ietf
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay map 192.1.1.1  100                        //本地DLCI=100与对端路由器R的IP做关联映射
R1(config-if)#no inverse-arp
R1(config)#router rip
R1(config)#network 192.1.1.0
R2:
R2(config)#interface s0
R2(config-if)#ip address 192.1.1.4 255.255.255.0
R2(config-if)#encapsulation frame-relay ietf
R2(config-if)#frame-relay lmi-type ansi
R2(config-if)#frame-relay map 192.1.1.1  400                          //本地DLCI=400与对端路由器R的IP做关联映射
R2(config-if)#no inverse-arp
R2(config)#router rip
R2(config)#network 192.1.1.0
 
三、星型拓扑下的点对点模式:
如下所示: 
 
帧中继的浅析-----星型拓扑的点对多点模式与点对点模式的比较 - 漠雨 - 沙漠里de烟雨
 
 配置方法如下:
R:
R(config)#interface S0
R(config-if)no ip address                                                     //主接口S0不要配置IP

R(config)#interface s0.1 point-to-point                                // 设置子接口S0.1为点对点模式
R(config-if)#ip address 192.1.1.1 255.255.255.0                //设S0.1接口的IP
R(config-if)#encapsulation frame-relay ietf                          //封装帧中继类型为IETF
R(config-if)#frame-relay lmi-type ansi                                  //设置帧中继LMI类型为ANSI
R(config-if)#frame-relay map interface-dlci  200                  //本地DLCI=200与对端路由器R1做关联映射
R(config-if)#no inverse-arp                                                  //禁止反向域名解析

R(config)#interface s0.2 point-to-point                                // 设置子接口S0.2为点对点模式
R(config-if)#ip address 192.1.2.1 255.255.255.0                //设S0.2接口的IP
R(config-if)#encapsulation frame-relay ietf                          //封装帧中继类型为IETF
R(config-if)#frame-relay lmi-type ansi                                  //设置帧中继LMI类型为ANSI
R(config-if)#frame-relay map interface-dlci  300                  //本地DLCI=300与对端路由器R2做关联映射
R(config-if)#no inverse-arp                                                  //禁止反向域名解析
R(config)#router rip                                                             //启用RIP路由协议
R(config)#network 192.1.1.0                                                //通告网段192.168.1.0
R(config)#network 192.1.2.0                                                //通告网段192.168.2.0
 
R1:
R1(config)#interface s0
R1(config-if)#ip address 192.1.3.1 255.255.255.0
R1(config-if)#encapsulation frame-relay ietf
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay map interface-dlci  100                  //本地DLCI=100与对端路由器R做关联映射
R1(config-if)#no inverse-arp
R1(config)#router rip
R1(config)#network 192.1.3.0
R2:
R2(config)#interface s0
R2(config-if)#ip address 192.1.4.1 255.255.255.0
R2(config-if)#encapsulation frame-relay ietf
R2(config-if)#frame-relay lmi-type ansi
R2(config-if)#frame-relay map interface-dlci  400                   //本地DLCI=400与对端路由器R做关联映射
R2(config-if)#no inverse-arp
R2(config)#router rip
R2(config)#network 192.1.4.0
 
如上所述,可以对这两种模式进行比较,从而可以区分什么时候应该采用“点到多点”,什么时候应该用“点到点”:
 
          帧中继的“点对多点”模式 
1、 所有PVC均在同一个子网,共享同一个广播域;
2、使用RIP或IGRP等距离矢量协议会产生“水平分割”问题;
3、中心节点一个物理接口承载多个PVC,PVC之间通过划分时隙来分隔;
4、使用RIP协议后,分支只能与中心节点通信,分支间不能通信,形成了一个中央集权模式的网络;
 5、配置时,须得将PVC对端路由器接口IP与本地DLCI进行关联。
 
          帧中继的“点对点”模式
1、所有PVC均在一个独立的网段;
2、划分的子接口分割了广播域,使RIP不会产生水平分割问题;
3、中心节点一个物理接口承载多个PVC,PVC之间通过子接口来分隔;
4、使用RIP协议后,通过子网通告,各分支能够实现互通,形成一个对等的网络;
5、因PVC两端的路由器接口在同一网段,故只需将本地子接口与本地DLCI 进行关联即可。
 
由以上分析可以看出,当一企业或单位的总部希望各分支公司或机构只能与总部进行通信的话,采用第一种方式,即点到多点模式,反之,如果希望某些有业务或事务往来的分公司或机构,则采用第二种方式,即点对点模式。如果只是某一部分相互可以互访,而其它部分节点只能与总部互访,对于只能与总部互访的分支节点,则只需在总部边缘路由器的对应子接口采用点对多点模式,且在其分支节点中的接口采用DLCI与总部路由器对应子接口的IP进行关联。
例如,分支节点R5只能与中心节点R进行通信,不能与其它分支进行互访,修改配置如下:
      在中心节点R上:
R(config)#interface s0.5 multipoint                                  //设置子接口S0.5为点对多点模式
R(config-if)#ip address 192.1.5.1 255.255.255.0           //设置子接口S0.5的IP地址为192.1.5.1/24
R(config-if)#frame-relay map 192.1.6.1  500                  //本地DLCI=500与对端路由器R5的IP做关联映射
 
      在分支节点R5上:
R5(config)#interface S0
R5(config-if)#ip address 192.1.5.2 255.255.255.0        //设置R5的IP地址为192.1.5.2/24
R5(config-if)#frame-relay map 192.168.5.1  600           //本地DLCI=600与中心节点R的IP做关联映射
 
  评论这张
 
阅读(2164)| 评论(0)

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018